Riverty Status Page

Riverty Customer Support is experiencing disruptions

Incident Report for Riverty

Resolved

We would like to inform that the issue disrupting customer service is now being resolved.
Posted Sep 12, 2023 - 10:07 CEST

Identified

Unfortunately, we have to inform you about an ongoing incident that is disrupting our customer support phone lines
The service has been affected since 09:00 am CET.
We are currently working on resolving the issue.
Posted Sep 12, 2023 - 10:05 CEST
This incident affected: Customer Service (Customer Service Netherlands).